Magazine

Saut de ligne avec wordpress : TinyMCE Advanced (cqfd)

Publié le 09 novembre 2010 par Graphiste_web

J’ai trouvé ! C’est bon! La solution qui évite le formatage automatique de WordPress qui empêche le saut de ligne !

J’aimerai pouvoir vous expliquer pourquoi ; mais vraiment, je ne sais pas. WordPress a volontairement décidé d’empêcher le saut de ligne dans les articles (appuyer plusieurs fois sur “ENTRER” afin de donner un plus grand espace à vos textes et aérer vos articles). C’est une méthode de leur part vraiment agaçante, et je ne sais pas pour vous, mais moi, je déteste quand la machine ne fait pas ce que je souhaite !

Pour régler ce problème, j’ai enfin une solution qui évite la méthode brutal d’aller dans les fichiers wp-include/ et modifier les sources. C’est simple, c’est un plug-in !

TinyMCE Advanced

Plug-in disponible ici -> http://wordpress.org/extend/plugins/tinymce-advanced/

Bien plus qu’un jouet qui va régler le bug, c’est surement un plug-in qui serat pour vous (ça l’es pour moi) par défaut dans vos réalisations WordPress.

En effet il permet non seulement d’autoriser le saut de ligne (god bless it) mais améliore grandement votre éditeur de texte en rajoutant quelques options sympathiques et vous permet de personnaliser en rajoutant/enlevant certaines options de votre éditeur, un bon moyen pour gagner du temps !

Pour cela, une fois le plug-in installé, allez dans “réglages du site”, puis “TinyMCE Advanced“, dedans vous aurez toutes les options souhaitez, dont le fameux “stop removing <p> and <br>

Enjoy !


Retour à La Une de Logo Paperblog

A propos de l’auteur


Graphiste_web 53 partages Voir son profil
Voir son blog

l'auteur n'a pas encore renseigné son compte l'auteur n'a pas encore renseigné son compte l'auteur n'a pas encore renseigné son compte

Dossier Paperblog