Magazine Internet

Rendre ses commentaires compatible avec la 2.7

Publié le 17 février 2009 par Papy Nerds

Pour vos anciens thèmes, il n’y à rien de plus facile pour rendre ses commentaires compatibles avec la version 2.7 de Wordpress.
Il vous suffit pour cela de remplacer votre boucle de commentaires qui commence par :

<?php if ($comments) : ?>

et de remplacer la totalité de votre boucle par :

<?php
if (have_comments()) : ?>
<h4 id="comments"><?php comments_number('No Comments', 'One Comment', '% Comments' );?></h4>
<ul class="commentlist">
<?php wp_list_comments(); ?>
</ul>
<div class="navigation">
<div class="alignleft"><?php previous_comments_link() ?></div>
<div class="alignright"><?php next_comments_link() ?></div>
</div>
<?php else : // this is displayed if there are no comments so far ?>
<?php if ('open' == $post->comment_status) :
// If comments are open, but there are no comments.
else : // comments are closed
endif;
endif;
?>

Voilà, il ne vous reste plus qu’à mettre votre thème à jour…


Retour à La Une de Logo Paperblog

A propos de l’auteur


Papy Nerds 22 partages Voir son profil
Voir son blog

l'auteur n'a pas encore renseigné son compte l'auteur n'a pas encore renseigné son compte l'auteur n'a pas encore renseigné son compte

Dossier Paperblog