Magazine Humour

Tutoriel - Exploiter Ziki avec Windev

Publié le 31 octobre 2007 par Stéphane Bertolotti

Il est possible assez simplement d’exploiter les données de Ziki via Windev grâce à l’API mise à disposition.

L’essentiel est de bien prendre en main les fonctions de requête Http et la manipulation des fichiers XML.

1. Faire une recherche de personne et récupérer les informations disponibles.

Trois possibilités de recherche :

  1. Par Nom
  2. Par Prénom
  3. Par Nom et Prénom

Pour effectuer ces recherches, il faudra donc créer deux champs de recherche, nom et prénom.

Pour traiter la recherche, il faudra tester quelles sont les champs renseignés pour envoyer la bonne requête. Un test de chaine vide sur les champs de saisie suffira.

Dans le code suivant,

  • SNomZiki est le champs de saisie Nom
  • SPrenomZiki est le champs de saisie Prénom
  • monresultat est une variable de type chaîne

SI SNomZiki <> “” ET SPrenomZiki <> “” ALORS
HTTPRequête(”http://www.ziki.com/fr/web.xml?first_name=” + SPrenomZiki + “&last_name=” + SNomZiki)
monresultat = HTTPDonneRésultat(HTTPRésultat)
fSauveTexte(”C:\Temp\resultat.xml”, monresultat)
SINON
SI SNomZiki <> “” ET SPrenomZiki = “” ALORS
HTTPRequête(”http://www.ziki.com/fr/web.xml?last_name=” + SNomZiki)
monresultat = HTTPDonneRésultat(HTTPRésultat)
fSauveTexte(”C:\Temp\resultat.xml”, monresultat)
SINON
SI SNomZiki = “” ET SPrenomZiki <> “” ALORS
HTTPRequête(”http://www.ziki.com/fr/web.xml?first_name=” + SPrenomZiki)
monresultat = HTTPDonneRésultat(HTTPRésultat)
fSauveTexte(”C:\Temp\resultat.xml”, monresultat)
FIN
FIN

FIN

Déroulement de l’action de recherche :

(more…)


Vous pourriez être intéressé par :

Retour à La Une de Logo Paperblog

Ces articles peuvent vous intéresser :

A propos de l’auteur


Stéphane Bertolotti 28 partages Voir son profil
Voir son blog

l'auteur n'a pas encore renseigné son compte l'auteur n'a pas encore renseigné son compte l'auteur n'a pas encore renseigné son compte

Magazines