Magazine High tech

Résoudre le Cannot modify header information pour WordPress

Publié le 24 février 2011 par Tatam

En souhaitant mettre à jour mon bon vieux WordPress 3.0.1 vers WordPress 3.1, et après avoir modifié mon fichier de configuration pour WordPress, j’ai obtenu une erreur pour le moins importante sur de multiples pages d’administration : Cannot modify header information.

Si vous obtenez le même problème, il existe une solution très simple. On y pense pas au premier coup d’oeil, donc attention.

UTF-8 or not UTF-8 ?

L’encodage des fichiers PHP de votre installation de WordPress sont encodés en UTF-8. Lors d’une modification vous devez choisir ce format d’encodage dans les préférences de votre logiciel d’édition de code préféré (pour mon cas, il s’agit de NotePad++).

Cette erreur provient lorsqu’on essaye de modifier des entêtes de documents alors que des informations ont déjà été envoyées. Pour fonctionner correctement celui-ci doit être enregistré en UTF-8 sans BOM. Car avec l’UTF-8 tout court, le caractère d’identification est mal compris, et génère une erreur à l’écran (le célèbre Cannot modify header information).

Par exemple, pour NotePad++, vous devez sélectionné cette option :

Résoudre le Cannot modify header information pour WordPress


Retour à La Une de Logo Paperblog

A propos de l’auteur


Tatam 410 partages Voir son profil
Voir son blog

l'auteur n'a pas encore renseigné son compte l'auteur n'a pas encore renseigné son compte l'auteur n'a pas encore renseigné son compte

Dossier Paperblog

Magazines